JPA 2.2 support

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

JPA 2.2 support

Andrei Shakirin
Hi,

Does Aries support JPA 2.2 specification?

I am trying to install Hibernate 5 under Karaf 4 with Aries JPA 2.7.2 features.
The Hibernate versions 5.2.X (JPA 2.1) are working, but I have an issue with installing Hibernate 5.3.X, 5.4.X  (JPA 2.2).

Regards,
Andrei.

As a recipient of an email from Talend, your contact personal data will be on our systems. Please see our contacts privacy notice at Talend, Inc. <https://www.talend.com/contacts-privacy-policy/>


Reply | Threaded
Open this post in threaded view
|

Re: JPA 2.2 support

Timothy Ward-2
To my knowledge this hasn’t been done yet. It shouldn’t be a big job to add it if you wanted to submit a patch.

All the best,

Tim

> On 22 May 2019, at 16:16, Andrei Shakirin <[hidden email]> wrote:
>
> Hi,
>
> Does Aries support JPA 2.2 specification?
>
> I am trying to install Hibernate 5 under Karaf 4 with Aries JPA 2.7.2 features.
> The Hibernate versions 5.2.X (JPA 2.1) are working, but I have an issue with installing Hibernate 5.3.X, 5.4.X  (JPA 2.2).
>
> Regards,
> Andrei.
>
> As a recipient of an email from Talend, your contact personal data will be on our systems. Please see our contacts privacy notice at Talend, Inc. <https://www.talend.com/contacts-privacy-policy/>
>
>