jax-rs whiteboard requires new contract

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

jax-rs whiteboard requires new contract

marc.schlegel
Hello everyone

I was about to test the jax-rs whiteboard impl provided by Aries, but Bndtools fails to resolve the newly added contract

->  Unable to resolve org.apache.aries.jax.rs.whiteboard version=0.0.1.201706301655:
   missing requirement &(osgi.contract=JavaJAXRS)(version=2.0.0)]]]

This has recently been added [1] and I am wondering where I can find the appropriate provider? Is this something the HttpService has to provide ( I am on Pax-Web)?


[1] https://github.com/apache/aries-jax-rs-whiteboard/commit/faf6b1f693533efb0c52156d987e467c5e9decbd

regards
Marc

Reply | Threaded
Open this post in threaded view
|

Re: jax-rs whiteboard requires new contract

Carlos Sierra Andrés-2

hey Marc,

I believe this might be what you are looking for: https://github.com/apache/aries-jax-rs-whiteboard/tree/master/javax-ws-rs/2_0

let us know if it works for you.

Bests.

Carlos


El 17/7/17 a las 13:36, [hidden email] escribió:
Hello everyone

I was about to test the jax-rs whiteboard impl provided by Aries, but Bndtools fails to resolve the newly added contract

->  Unable to resolve org.apache.aries.jax.rs.whiteboard version=0.0.1.201706301655:
   missing requirement &(osgi.contract=JavaJAXRS)(version=2.0.0)]]]

This has recently been added [1] and I am wondering where I can find the appropriate provider? Is this something the HttpService has to provide ( I am on Pax-Web)?


[1] https://github.com/apache/aries-jax-rs-whiteboard/commit/faf6b1f693533efb0c52156d987e467c5e9decbd

regards
Marc

Reply | Threaded
Open this post in threaded view
|

Antwort: Re: jax-rs whiteboard requires new contract

marc.schlegel
In reply to this post by marc.schlegel
Hi Carlos

Yes, that was what I was looking for. I didnt realize that there is now a second API bundle

Thanks
Marc




Von:        "Carlos Sierra Andrés" <[hidden email]>
An:        [hidden email], [hidden email],
Datum:        17.07.2017 13:48
Betreff:        Re: jax-rs whiteboard requires new contract





hey Marc,

I believe this might be what you are looking for: https://github.com/apache/aries-jax-rs-whiteboard/tree/master/javax-ws-rs/2_0

let us know if it works for you.

Bests.

Carlos


El 17/7/17 a las 13:36, [hidden email] escribió:
Hello everyone

I was about to test the jax-rs whiteboard impl provided by Aries, but Bndtools fails to resolve the newly added contract


->  Unable to resolve org.apache.aries.jax.rs.whiteboard version=0.0.1.201706301655:

   missing requirement &(osgi.contract=JavaJAXRS)(version=2.0.0)]]]


This has recently been added [1] and I am wondering where I can find the appropriate provider? Is this something the HttpService has to provide ( I am on Pax-Web)?



[1]
https://github.com/apache/aries-jax-rs-whiteboard/commit/faf6b1f693533efb0c52156d987e467c5e9decbd

regards
Marc